Beam Login Issues
Incident Report for Skykit
Resolved
No further issues reported.
Posted Jan 21, 2023 - 13:46 CST
Monitoring
At this time, we have not been able to identify any issue with our overall platform or services. We will continue to monitor and work on any reported login issues on a case by case basis.
Posted Jan 09, 2023 - 20:25 CST
Investigating
We have received reports of users experiencing irregular behavior when logging in. We recommend clearing your browser cache as a first troubleshooting step. If you are unable to log in please email our support team at Support@skykit.com.

Our dev team is currently reviewing the reports and determining whether changes are necessary
Posted Jan 06, 2023 - 13:32 CST
This incident affected: Beam.